UniFi — Методы Уровня 3 для настройки UAP и управления ею

Описаны различные методы Уровня 3, применяемые при развертывании UAP.

При развертывании точек доступа, во многих случаях невозможна или нежелательна работа контроллера на площадке. В таких случаях можно запустить контроллер в облаке или в Вашем NOC. Допустим, мы реализуем крупный проект с многими UAP. Можно действовать следующим образом:

  • На Amazon создадим объект виртуального контроллера на EC2.

  • Разместим и настроим несколько точек доступа в нашей лаборатории и отрегулируем в соответствии со своими предпочтениями гостевые порталы.

  • Находясь на площадке клиента, откроем в браузере контроллер, функционирующий в облаке.

  • Сконфигурируем DHCP- и DNS- сервера, либо просто применим утилиту UniFi Discovery, чтобы все локальные AP информировали контроллер по обратному каналу.

  • Управление и мониторинг в реальном времени можно осуществлять из любого места, при этом Amazon будет предоставлять хорошие конфигурации межсетевого экрана.

Содержание

  1. Начальная установка

  2. Утилита Discovery

  3. DNS

  4. DHCP option 43

  5. SSH

 

Начальная установка

Перед тем, как начинать с управлением Уровня 3, пожалуйста, ознакомьтесь с тем, как работают устройства UniFi (например, в каком месте находятся AP и контроллер на Уровне 2). При управлении Уровня 3 добавляется множество дополнительных настроек (то есть возрастает сложность).

UniFi AP по умолчанию для информирования использует URL http://unifi:8080/inform. Далее, использование DHCP option 43, либо DNS позволяет AP узнать IP-адрес контроллера.

Утилита Discovery

Не во многих средах имеется конфигурируемый DHCP-сервер, еще менее вероятно это для DNS-сервера. Поэтому разработана утилита UniFi Discovery. Она слушает широковещательные / многоадресные пакеты, поступающие от точек доступа UniFi AP и позволяет Вам сообщить AP, чтобы информирование производилось по любому выбранному Вами URL. (Будут отображаться только AP в состоянии по умолчанию, либо не контактирующие ни с каким контроллером.)

Утилита UniFi Discovery устанавливается вместе с Вашим контроллером UniFi.

  • В Windows, она находится в разделе меню «Пуск«: Start Menu->Ubiquiti UniFi->UniFi-Discover

  • На Mac запустите приложение /Applications/UniFi-Discover.app (либо используйте Spotlight, чтобы отыскать его)

  • Запустите «java -jar <unifi_base>/lib/ace.jar discover»

Чтобы выполнить настройку Уровня L3 с помощью утилиты обнаружения:

  1. Дождитесь появления AP.

  2. Если AP не находится в состоянии по умолчанию, щелкните «reset» (переустановить), введите имя пользователя / пароль SSH, затем щелкните «Apply» (Применить).

  3. Щелкните по «manage» (управлять), измените URL информирования, установите имя пользователя / пароль SSH ubnt / ubnt и щелкните «Apply» (Применить).

  4. Откройте браузер и по удаленному доступу войдите в контроллер UniFi; Вы увидите сообщение «Pending Approval» (Разрешение отложено).

  5. Щелкните по «approve» (разрешить). После этого Вы увидите, что контроллер перейдет в состояние «Adopting» (Идет настройка). Игнорируйте иногда появляющиеся сообщения «Adoption Failed» (Сбой настройки) и «Disconnected» (АР отключена).

  6. Снова выполните [3] (завершения [5] ждать нет необходимости)

  7. Теперь АР управляется контроллером.

Сразу после завершения настройки контроллер автоматически обновит устройства.

Доступна также опция Ubiquiti Discovery Tool Chrome Extension (расширение браузера Chrome), ее можно загрузить непосредственно из браузера Google Chrome здесь, или с страницы загрузок UBNT.

DNS

  • Вам необходимо сконфигурировать Ваш DNS-сервер, чтобы привязать ‘unifi’ к IP-адресу Вашего контроллера. Убедитесь, что AP может привязать доменное имя контроллера. Например, если Вы зададите http://XYZ:8080/inform, то выдавая с АР команду ping, Вы сможете определить привязано / достижимо ли устройство XYZ.

  • Либо, используйте FQDN для URL информирования контроллера http://FQDN:8080/inform

  • Устранение неполадок — AP (с статическим IP-адресом) не удается соединиться с контроллером L3

    • когда AP сконфигурирована из DHCP со статическим адресом в пользовательском интерфейсе (UI) контроллера, убедитесь, что Вы ввели IP-адрес DNS. Если не ввели, то AP не сможет контактировать с DNS для привязки доменного имени контроллера.

    • Если AP была переустановлена (нажатием кнопки reset (переустановка)), дважды убедитесь, что AP информирована (используйте утилиту обнаружения) о местоположении контроллера (в следующей версии 2.3.0 это будет доработано).

DHCP option 43

Если используются маршрутизаторы Ubiquiti EdgeMax, то может быть реализован DHCP option 43. Для этого введите IP-адрес контроллера UniFi в поле «unifi» на dhcp-сервере.

Чтобы использовать DHCP option 43, Вам потребуется сконфигурировать DHCP-сервер. Например:

В Linux, ISC DHCP-сервер: dhcpd.conf

# …

option space ubnt;

option ubnt.unifi-address code 1 = ip-address;

class «ubnt» {

match if substring (option vendor-class-identifier, 0, 4) = «ubnt»;

option vendor-class-identifier «ubnt»;

vendor-option-space ubnt;

}

subnet 10.10.10.0 netmask 255.255.255.0 {

range 10.10.10.100 10.10.10.160;

option ubnt.unifi-address 201.10.7.31; ### IP-адрес контроллера UniFi ###

option routers 10.10.10.2;

option broadcast-address 10.10.10.255;

option domain-name-servers 168.95.1.1, 8.8.8.8;

# …

}

Интерфейс командной строки Cisco

# допустим, Ваш UniFi находится в 192.168.3.10

ip dhcp pool <имя пула>

network <ip-адрес сети> <маска сети>

default-router <IP-адрес маршрутизатора, выбираемого по умолчанию>

dns-server <IP-адрес dns-сервера>

option 43 hex 0104C0A8030A # 192.168.3.10 -> CO A8 03 0A

# Почему 0104C0A8030A ?

#

# 01: субопция

# 04: длина payload (должна быть равна 4)

# C0A8030A: 192.168.3.10

Интерфейс командной строки Mikrotik

/ip dhcp-server option add code=43 name=unifi value=0x0104C0A8030A

/ip dhcp-server network set 0 dhcp-option=unifi

# Почему 0104C0A8030A ?

#

# 01: субопция

# 04: длина payload (должна быть равна 4)

# C0A8030A: 192.168.3.10

У Cisco есть хорошее описание настройки DHCP option 43.

Чтобы использовать IP-адрес контроллера

  • Вы также можете использовать IP-адрес контроллера в URL информирования (вместо доменного имени).

SSH

Если Вы можете использовать SSH в АР, то возможно выполнить настройку L3 из командной строки:

# 1. Убедитесь, что на AP работает та же версия фирменного ПО, что и на контроллере. Если это не так, см. руководство Обновление фирменного ПО UniFi по SSH.

# 2. Убедитесь, что AP находится в состоянии заводских настроек, выбираемых по умолчанию

# если это не так, выполните команду

# syswrapper.sh restore-default

# 3. Войдите через ssh в устройство и введите команду

mca-cli

# Интерфейс командной строки:

set-inform http://ip-of-controller:8080/inform

 

Другие статьи по этой теме

Как установить соединение, используя SSH   

Все авторские права и другие права интеллектуальной собственности на данные материалы являются собственностью Компании «Рутстор» (ROOTSTORE). При использовании данного материала ссылка на сайт rootstore.ru обязательна.

Авторизация
*
*
Регистрация
*
*
*
*
Генерация пароля
Заказать звонок



Купить в 1 клик